clipboard not working in windows 7 ( internal error ) service missing

As of Windows 7 (Vista in fact), The Clipboard service is missing. Apparently nobody knows (or cares) where it went, cause you can search for answers on-line till you grow a beard…

So here is what I did.

THE PROBLEM: This time it started with notepad++ where I did “Plugins –> NppExport –> Copy all formats to clipboard” in an empty document. That threw me a “runPluginCommand Exception” and as a result broke the clipboard functions.

Copy paste stopped working. Copy in Adobe threw a “there was an error while copying to the Clibboard. An internal error occured.” and Office complained that “item was not send to clipboard” when copy.

THE SOLUTION: Now, to find out what’s going on, I found a little tool, called GetOpenClipboardWindow , which can be downloaded here:

When you run this program, it’ll try to open and close the clipboard. When there is an error, it’ll tell you which error.
In my case:

So it seems that process 5080 is blocking the clipboard.
To see what process has ID 5080 fire up msinfo32 ( press Windows-key + R –> then type msinfo32 ). This will launche an extended information applet.
Choose “Software enviroment” -> “Running Tasks”:

Once there , click on the column top “Process ID” to sort the list on process id’s.
In this example process 5080 is notepad++ who is the app blocking clipboard operations:

So.. this was easy, just killed (exit) notepad++ and clipboard worked again.

In your case, you’ll find other causes and issues. But because microsoft robbed us from just restarting the service, this is the only thing I could come up with. If I find a way to restart the clipboard, i’ll update this post.

If YOU happend to know how to restart the clipboard in windows 7, please put your solution in the comment section below. 🙂

5 thoughts on “clipboard not working in windows 7 ( internal error ) service missing

  1. Thanks! That fixed the issue. It was MS Word causing my problem. Rogue process, wasn’t even running in the foreground.

  2. This solved my issue! It was PrintKey2000. Of course a reboot would have fixed things but I needed to copy and paste the contents of a mysql processlist. Not something I could reproduce easily.

Leave a Comment